#0 

09-04-2013 22:29:03

Copland
Modérateur
Lieu: ZarbiLand
Date d'inscription: 22-09-2006
Messages: 657
Site web

Bonjour à tous,
Voilà cela fait déjà pas mal de temps que j’essaie d'updater mon projet avec les dernières SVN mais il se trouve que tous mes systèmes de texturage parte complètement en vrille...
L'exemple 11 fourni avec Irrlicht ne marche plus depuis plusieurs révisions.
Avez-vous les mêmes soucis et sur quelle SVN vous êtes vous arrêté ?
Je suis sans cesse en train d'essayer et puis finalement downgrader, c'est frustrant à force !


Config : I5 2400, ATI HD6870 1Go DDR5, 4Go DDR3.
Single Boot : Windows Seven.

Hors ligne


#1 

21-12-2014 10:28:38

Copland
Modérateur
Lieu: ZarbiLand
Date d'inscription: 22-09-2006
Messages: 657
Site web

Salut les amis,
Je me remets doucement à mon vieux code et donc j'ai pris la SVN rev 5000 mais je n'arrive pas à afficher un quad face à la camera avec mon bon vieux code :

   virtual void render()
   {
       u16 indices[] = {    0,1,2, 3,2,1    };
       video::IVideoDriver* driver = SceneManager->getVideoDriver();

      driver->setMaterial(Material);
      driver->setTransform(video::ETS_WORLD, AbsoluteTransformation);
      driver->drawIndexedTriangleList(&Vertices[0], 4, &indices[0], 2);
   }

Vous avez une idée ? smile


Config : I5 2400, ATI HD6870 1Go DDR5, 4Go DDR3.
Single Boot : Windows Seven.

Hors ligne


#2 

21-12-2014 10:43:50

Copland
Modérateur
Lieu: ZarbiLand
Date d'inscription: 22-09-2006
Messages: 657
Site web

Bon en fait j'ai trouvé, c'est juste un bug de rendu avec la gui d'irrlicht....


Config : I5 2400, ATI HD6870 1Go DDR5, 4Go DDR3.
Single Boot : Windows Seven.

Hors ligne


#3 

21-12-2014 15:13:55

Magun
SleekThink Producer
Lieu: Punakha
Date d'inscription: 18-11-2007
Messages: 902
Corrections: 2
Site web

plus d'info sur le bug ?
perso pas de soucis a déplorer sur les dernier svn de mon coter

par contre réinitialise view et projection

Code:

            driver->setTransform(irr::video::ETS_PROJECTION, irr::core::IdentityMatrix);
            driver->setTransform(irr::video::ETS_VIEW, irr::core::IdentityMatrix);

Hors ligne


#4 

21-12-2014 17:38:13

Copland
Modérateur
Lieu: ZarbiLand
Date d'inscription: 22-09-2006
Messages: 657
Site web

J'ai un soucis d'ordre de rendu avec la gui et mon quad en fait....
J'utilise un Quad fullscreen pour rendre un de mes shaders et si je fais un env->drawAll() à la fin de ma boucle, mon quad n'est tout simplement pas visible.
Pour les matrices pour quelle raison tu réinits la vue et la projection ?
Merci

Dernière modification par Copland (21-12-2014 17:41:42)


Config : I5 2400, ATI HD6870 1Go DDR5, 4Go DDR3.
Single Boot : Windows Seven.

Hors ligne


#5 

21-12-2014 19:20:29

Magun
SleekThink Producer
Lieu: Punakha
Date d'inscription: 18-11-2007
Messages: 902
Corrections: 2
Site web

simplement pour suprimmer les transformations matricielle engendré par la caméra du coup tu te retrouve bien en face sur un plan 2d l'or du rendue
d'ailleur perso le rendue d'un fullscreen quad n'utilise que des matrice identitaires view/projection/world, c'est plus éfficient surtout pour toi avec ton system de multipass
sinon tu passe par draw2DVertexPrimitiveList, le principe est identique a par que tu passe par une matrice orthographique

après ton drawAll est opéré avans ou après le rendue de ton quad ?

Hors ligne


#6 

21-12-2014 22:09:10

Copland
Modérateur
Lieu: ZarbiLand
Date d'inscription: 22-09-2006
Messages: 657
Site web

Le drawAll est effectué après...Ptêtre un soucis de Z order je sais pas


Config : I5 2400, ATI HD6870 1Go DDR5, 4Go DDR3.
Single Boot : Windows Seven.

Hors ligne


#7 

24-12-2014 11:31:59

Copland
Modérateur
Lieu: ZarbiLand
Date d'inscription: 22-09-2006
Messages: 657
Site web

Est-ce que tu pourrais voir si chez toi avec la SVN tu rencontres pas un crash avec cette méthode : getSceneNodeAndCollisionPointFromRay ?
Mon éditeur crashe systématiquement sur cette méthode, alors qu'avant ça fonctionnait bien...


Config : I5 2400, ATI HD6870 1Go DDR5, 4Go DDR3.
Single Boot : Windows Seven.

Hors ligne


#8 

24-12-2014 15:21:31

Magun
SleekThink Producer
Lieu: Punakha
Date d'inscription: 18-11-2007
Messages: 902
Corrections: 2
Site web

je regarde

....

non pas de soucis (example 7 marche)

Hors ligne


#9 

24-12-2014 17:52:22

Copland
Modérateur
Lieu: ZarbiLand
Date d'inscription: 22-09-2006
Messages: 657
Site web

C'est mystèrieu, ça plante systématiquement chez moi sur cette méthode tant pis je la remplace par une autre smile


Config : I5 2400, ATI HD6870 1Go DDR5, 4Go DDR3.
Single Boot : Windows Seven.

Hors ligne


Options Liens officiels Caractéristiques Statistiques Communauté
Corrections
irrlicht
irrklang
irredit
irrxml
xhtml 1.0
css 2.1
Propulsé par FluxBB
Traduit par FluxBB.fr
Analysé par
872 membres
1423 sujets
11109 messages
Dernier membre inscrit: Glider
9 invités en ligne
Aucun membre connecté
RSS Feed

[ Générée en 0.087 sec., 13 requêtes exécutées ]